Presiona ENTER para ver los resultados o ESC para cancelar.

Actualización de PHP: 5.6 a 7.0

El próximo día 7 de Noviembre de 2017 actualizaremos todos nuestros servidores de alojamiento a PHP 7.0, un cambio que traerá una gran cantidad de mejoras tanto a nivel de seguridad como de rendimiento, se trata de un cambio necesario dado que la versión de PHP 5.6 que utilizamos actualmente dejará de tener soporte a finales de 2018, mantener esta versión durante mucho más tiempo puede provocar problemas futuros de seguridad.

Actualizar ahora a PHP 7.0 nos permitirá actualizar en un futuro a versiones más recientes con más celeridad.

¿Mi sitio web dejará de funcionar?

Si utilizas CMS desarrollado por terceros

Si utilizas una aplicación como WordPress, Joomla, Prestashop, etc. y la tienes actualizada a la última versión disponible, no deberías tener problemas al actualizar a PHP 7.0, aún así te recomendamos revisar la documentación oficial de la aplicación para determinar si tendrás problemas en ese aspecto. Es importante revisar también la documentación de los plugins, módulos o temas que utilizas, para estar completamente seguro de que funcionará.

En caso de utilizar una versión antigua de esa aplicación, es posible que no sea compatible con PHP 7.0, por lo que te recomendamos actualizarla cuanto antes para evitar que el sitio web deje de funcionar, recuerda realizar copias de seguridad tanto de los archivos del FTP como de la base de datos antes, para poder volver atrás en caso de que falle esta actualización.

Listado de las aplicaciones más utilizadas compatibles con PHP 7.0

Las siguientes aplicaciones son compatibles con PHP 7.0, aún así recomendamos revisar si los plugin, módulos y temas utilizados también lo son:

  • WordPress 3.9 o superior
  • Prestashop 1.6.1.4 o superior (fuente)
  • Joomla 3.5 o superior (fuente)
  • Moodle 3.0.1 o superior (fuente)
  • Drupal 8.0 o superior, Drupal 7.5 es parcialmente compatible (fuente)

Si utilizas una aplicación propia

Si por el contrario, haces uso de una aplicación desarrollada a medida, te recomendamos contactar con su desarrollador para que revise si la aplicación es compatible con esta nueva versión de PHP, encontrará todos los cambios a nivel de funcionamiento entre ambas versiones así como un manual para la migración de código de 5.6 a 7.0 en: Migrar de PHP 5.6.x a PHP 7.0.x

Quiero seguir con PHP 5.6

Si dispones de una aplicación creada a medida o, de una aplicación estándar muy antigua y crees que no podrás actualizarla antes del 7 de Noviembre, puedes solicitarnos vía ticket mantener tu sitio web en un servidor “legacy” que contará con PHP 5.6, el cual mantendremos activo hasta el 30 de Junio de 2018, de esta forma dispondrás de más tiempo para actualizar tu sitio web para hacerlo compatible con esta nueva versión de PHP.